forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Closes: https://bugs.gentoo.org/939167 Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
3 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST methane-2.0.1.tar.gz 1058487 BLAKE2B 2fc450c03dbbd57439b22e8e6ac8eebd2db18f97a3338180decdc0a437207b581a00e664e6353595c9eb50c16f7d9fead96bddf6ca50b67326ecea6dd4bb935a SHA512 96b005eb5964185adea89aa43afda375c474db8088a132b2d46a843a1eca6ba91f83bf41277a3f3cfa24c4f9b9dae7098527414284fd0521e92a34c225e06bd9 | ||
DIST methane-2.1.0.tar.gz 1059462 BLAKE2B 9a280875e5e7d44d4be88006fe97d3bbdb277f50609ad46fcdb33fcaaf10a22d8a7d4dc541637dd3f8a6e96b391b56533861d10abee38ddcb643f143c5ba632e SHA512 0854792d52a9f66d4fd43a6428fd27e92f1a8e324b085d0ab7612a7dac59e8e51d23acd10f4ac27975485049ea99e3ebb1ebae18f479a0c4286b7709438b06bf | ||
DIST methane.png 4034 BLAKE2B b10ebd8ca4bf2f6330aa89e3adb77a14bb183bf3d0dd40e305c87d58e0a6a4249662cdee8a457fc3df93a9c0b0daecf0dd8cb307c33a6b5f6e48543062b1b18f SHA512 a56e453c9971b8819904f19af4ed3e417ef0538f87bfa121918c8fa4f93c14ba922b7d29584f0c69497a7b56585a92a7df902997cf18f6f2672c31c960ea7772 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
--- a/Makefile~ 2024-08-20 13:13:02.000000000 +0200 | ||
+++ b/Makefile 2024-11-08 20:13:10.069539923 +0100 | ||
@@ -1,5 +1,6 @@ | ||
-METHANE_FLAGS = `pkg-config --cflags clanCore-4.2 clanDisplay-4.2 clanApp-4.2 clanGL-4.2 clanSound-4.2 libmikmod` -Isources | ||
-METHANE_LIBS = `pkg-config --libs clanCore-4.2 clanDisplay-4.2 clanApp-4.2 clanGL-4.2 clanSound-4.2 libmikmod` | ||
+PKG_CONFIG ?= pkg-config | ||
+METHANE_FLAGS = `$(PKG_CONFIG) --cflags clanCore-4.2 clanDisplay-4.2 clanApp-4.2 clanGL-4.2 clanSound-4.2 libmikmod` -Isources | ||
+METHANE_LIBS = `$(PKG_CONFIG) --libs clanCore-4.2 clanDisplay-4.2 clanApp-4.2 clanGL-4.2 clanSound-4.2 libmikmod` | ||
|
||
OBJF = sources/precomp.o \ | ||
sources/player.o \ | ||
@@ -37,7 +38,7 @@ | ||
@echo "=================================" | ||
|
||
methane: ${OBJF} | ||
- g++ ${CXXFLAGS} ${OBJF} -o methane ${METHANE_LIBS} | ||
+ $(CXX) ${CXXFLAGS} ${LDFLAGS} ${OBJF} -o methane ${METHANE_LIBS} | ||
|
||
clean: | ||
@rm -f sources/*.o | ||
@@ -49,5 +50,5 @@ | ||
# The main source code | ||
%.o:%.cpp | ||
@echo " Compiling $<..." | ||
- gcc ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@ | ||
+ $(CXX) ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit desktop toolchain-funcs | ||
|
||
DESCRIPTION="Port from an old Amiga game" | ||
HOMEPAGE="https://methane.sourceforge.net/ https://github.com/rombust/Methane" | ||
SRC_URI="https://github.com/rombust/Methane/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz | ||
https://src.fedoraproject.org/rpms/methane/raw/f41/f/methane.png | ||
" | ||
S="${WORKDIR}/Methane-${PV}" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
RDEPEND=" | ||
dev-games/clanlib:4.2[opengl,sound] | ||
media-libs/libmikmod | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="virtual/pkgconfig" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-makefile.patch" | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
tc-export PKG_CONFIG CXX | ||
} | ||
|
||
src_install() { | ||
dobin methane | ||
|
||
insinto /usr/share/${PN} | ||
doins resources/* | ||
|
||
doicon "${DISTDIR}/${PN}.png" | ||
make_desktop_entry ${PN} "Super Methane Brothers" | ||
HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt | ||
} |