Skip to content

Commit

Permalink
Move to new override syntax
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Müller <[email protected]>
  • Loading branch information
schnitzeltony committed Aug 15, 2021
1 parent 88a5cee commit 42a6ec9
Show file tree
Hide file tree
Showing 130 changed files with 321 additions and 321 deletions.
4 changes: 2 additions & 2 deletions appends/meta-oe/wxwidgets_%.bbappend
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@

inherit binconfig

PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
PACKAGECONFIG[opengl] = ",,libglu"

do_patch[postfuncs] += "do_patch_nocross"
Expand All @@ -13,7 +13,7 @@ do_patch_nocross() {
sed -i 's:@cross_compiling@:no:g' ${S}/wx-config.in
}

do_compile_append() {
do_compile:append() {
if [ -L ${B}/wx-config ]; then
echo "wxwidget recipe is not yet updated to wx-config adjustments so we do"
# ${B}/wx-config is a symlink for build and not needed after compile
Expand Down
14 changes: 7 additions & 7 deletions appends/meta-qt5/python3-pyqt5_%.bbappend
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
BBCLASSEXTEND = "native"

DEPENDS_class-native = "qtbase-native sip3-native python3-native"
DEPENDS:class-native = "qtbase-native sip3-native python3-native"

PYQT_MODULES_class-native = "QtCore"
PYQT_MODULES:class-native = "QtCore"

# This is a copy from meta-qt5 adjusted to native staging
do_configure_prepend_class-native() {
do_configure:prepend:class-native() {
cd ${S}
echo "py_platform = linux" > pyqt.cfg
echo "py_inc_dir = %(sysroot)/$includedir/python%(py_major).%(py_minor)${PYTHON_ABI}" >> pyqt.cfg
Expand All @@ -28,10 +28,10 @@ do_configure_prepend_class-native() {
return 0
}

CFLAGS_append_class-native = " -I${STAGING_INCDIR_NATIVE}/${PYTHON_DIR}"
CXXFLAGS_append_class-native = " -I${STAGING_INCDIR_NATIVE}/${PYTHON_DIR}"
CFLAGS:append:class-native = " -I${STAGING_INCDIR_NATIVE}/${PYTHON_DIR}"
CXXFLAGS:append:class-native = " -I${STAGING_INCDIR_NATIVE}/${PYTHON_DIR}"

do_install_class-native() {
do_install:class-native() {
cd ${S}
oe_runmake MAKEFLAGS='-j 1' install

Expand All @@ -42,5 +42,5 @@ do_install_class-native() {
done
}

RDEPENDS_${PN}_class-native = ""
RDEPENDS:${PN}:class-native = ""

2 changes: 1 addition & 1 deletion appends/meta-qt5/qtbase-native_%.bbappend
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
PACKAGECONFIG_append = " gui imageformats"
PACKAGECONFIG:append = " gui imageformats"

2 changes: 1 addition & 1 deletion appends/meta-qt5/qttools_git.bbappend
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
# yeah I know yocto does not want us to change this
PACKAGECONFIG_append = "${@bb.utils.contains('BBFILE_COLLECTIONS', 'clang-layer', ' clang', '', d)}"
PACKAGECONFIG:append = "${@bb.utils.contains('BBFILE_COLLECTIONS', 'clang-layer', ' clang', '', d)}"
20 changes: 10 additions & 10 deletions classes/lv2-turtle-helper.bbclass
Original file line number Diff line number Diff line change
Expand Up @@ -12,12 +12,12 @@
# 3. Generate ttl-files at first boot / after package was installed


# File containing names of plugins to handle in do_compile_append
# File containing names of plugins to handle in do_compile:append
# Line-format expected: <some-path-in-build>/<plugin>.so
LV2_PLUGIN_INFO_FILE = "${WORKDIR}/lv2-ttl-generator-data"
LV2_PLUGIN_INFO_FILE_CLEANED = "${LV2_PLUGIN_INFO_FILE}-cleaned"

# File containing names of plugins to handle in do_compile_append
# File containing names of plugins to handle in do_compile:append
# Line-format expected: <path-ontarget>/<plugin>.so
LV2_PLUGIN_POSTINST_INFO_FILE = "${LV2_PLUGIN_INFO_FILE}-postinst"

Expand All @@ -38,21 +38,21 @@ do_ttl_sed() {
sed -i 's|"$GEN" "./$FILE"|echo "`realpath "./$FILE"`" >> ${LV2_PLUGIN_INFO_FILE}|g' ${S}/dpf/utils/generate-ttl.sh
}

do_configure_prepend() {
do_configure:prepend() {
# 1st configure?
if [ ! -f ${LV2_PLUGIN_INFO_FILE} ]; then
do_ttl_sed
fi
}

do_compile_prepend() {
do_compile:prepend() {
# remove plugin-info from previous build
rm -f ${LV2_PLUGIN_INFO_FILE}
rm -f ${LV2_PLUGIN_POSTINST_INFO_FILE}
}

do_compile[vardeps] += "LV2_TTL_GENERATOR"
do_compile_append() {
do_compile:append() {
rm -f ${LV2_PLUGIN_INFO_FILE_CLEANED}
if [ -e ${LV2_PLUGIN_INFO_FILE} ]; then
echo
Expand Down Expand Up @@ -106,7 +106,7 @@ python do_ttl_qa() {
bb.warn("%i of %i LV2-plugins in %s are postponed to post-install! Check %s and log.do_compile for details" % (num_plugins_postinst, num_plugins, name, lv2_plugin_postinst_info_file))
}

do_install_append() {
do_install:append() {
# create postinst manifest
if [ -e ${LV2_PLUGIN_POSTINST_INFO_FILE} ]; then
install -d ${D}`dirname ${LV2_POSTINST_MANIFEST}`
Expand All @@ -117,7 +117,7 @@ do_install_append() {
fi
}

pkg_postinst_ontarget_${PN_LV2}() {
pkg_postinst_ontarget:${PN_LV2}() {
if [ -e ${LV2_POSTINST_MANIFEST} ]; then
oldpath=`pwd`
for sofile in `cat ${LV2_POSTINST_MANIFEST}`; do
Expand All @@ -133,7 +133,7 @@ pkg_postinst_ontarget_${PN_LV2}() {
fi
}

pkg_prerm_${PN_LV2}() {
pkg_prerm:${PN_LV2}() {
if [ -e ${LV2_POSTINST_MANIFEST} ]; then
for sofile in `cat ${LV2_POSTINST_MANIFEST}`; do
path=`dirname "$sofile"`
Expand All @@ -144,5 +144,5 @@ pkg_prerm_${PN_LV2}() {
fi
}

FILES_${PN_LV2} += "${LV2_POSTINST_MANIFEST}"
RDEPENDS_${PN_LV2} += "lv2-ttl-generator"
FILES:${PN_LV2} += "${LV2_POSTINST_MANIFEST}"
RDEPENDS:${PN_LV2} += "lv2-ttl-generator"
10 changes: 5 additions & 5 deletions classes/pack_audio_plugins.bbclass
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,8 @@ inherit audio-plugin-common

PACKAGES =+ "${PN_DSSI} ${PN_LADSPA} ${PN_LV2} ${PN_VST} ${PN_VST3}"

FILES_${PN_DSSI} += "${libdir}/dssi"
FILES_${PN_LADSPA} += "${libdir}/ladspa"
FILES_${PN_LV2} += "${libdir}/lv2"
FILES_${PN_VST} += "${libdir}/vst"
FILES_${PN_VST3} += "${libdir}/vst3"
FILES:${PN_DSSI} += "${libdir}/dssi"
FILES:${PN_LADSPA} += "${libdir}/ladspa"
FILES:${PN_LV2} += "${libdir}/lv2"
FILES:${PN_VST} += "${libdir}/vst"
FILES:${PN_VST3} += "${libdir}/vst3"
2 changes: 1 addition & 1 deletion classes/qemu-ext-musicians.bbclass
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
inherit qemu

DEPENDS_append = " qemu-native coreutils-native"
DEPENDS:append = " qemu-native coreutils-native"

# This is an extended/modified qemu.bbclass tailored four our needs:
#
Expand Down
16 changes: 8 additions & 8 deletions classes/qt5-translation.bbclass
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ DEPENDS += "qttools-native"
# default location
QT_TRANSLATION_FILES ??= "${datadir}/*/translations/*.qm ${datadir}/*/translations/*/*.qm ${datadir}/*/translations/*/*/*.qm"

FILES_${PN}-locale = "${datadir}/*/translations"
FILES:${PN}-locale = "${datadir}/*/translations"

python qt_do_split_locales() {
import glob
Expand Down Expand Up @@ -53,16 +53,16 @@ python qt_do_split_locales() {
files = ''
for transvar in d.getVar('QT_TRANSLATION_FILES').split():
files = '%s %s' % (files, transvar.replace('*.qm', '*_%s.qm' % l))
d.setVar('FILES_' + pkg, files )
d.setVar('RRECOMMENDS_' + pkg, '%svirtual-locale-%s' % (mlprefix, ln))
d.setVar('RPROVIDES_' + pkg, '%s-locale %s%s-translation' % (pn, mlprefix, ln))
d.setVar('SUMMARY_' + pkg, '%s - %s translations' % (summary, l))
d.setVar('DESCRIPTION_' + pkg, '%s This package contains language translation files for the %s locale.' % (description, l))
d.setVar('FILES:' + pkg, files )
d.setVar('RRECOMMENDS:' + pkg, '%svirtual-locale-%s' % (mlprefix, ln))
d.setVar('RPROVIDES:' + pkg, '%s-locale %s%s-translation' % (pn, mlprefix, ln))
d.setVar('SUMMARY:' + pkg, '%s - %s translations' % (summary, l))
d.setVar('DESCRIPTION:' + pkg, '%s This package contains language translation files for the %s locale.' % (description, l))
if locale_section:
d.setVar('SECTION_' + pkg, locale_section)
d.setVar('SECTION:' + pkg, locale_section)

d.setVar('PACKAGES', ' '.join(list(packages)))
}

PACKAGESPLITFUNCS_prepend = "qt_do_split_locales "
PACKAGESPLITFUNCS:prepend = "qt_do_split_locales "

2 changes: 1 addition & 1 deletion classes/wafold.bbclass
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# avoids build breaks when using no-static-libs.inc
DISABLE_STATIC = ""

EXTRA_OECONF_append = " ${PACKAGECONFIG_CONFARGS}"
EXTRA_OECONF:append = " ${PACKAGECONFIG_CONFARGS}"

python waf_preconfigure() {
import subprocess
Expand Down
2 changes: 1 addition & 1 deletion dynamic-layers/meta-rust/spotify-qt.bb
Original file line number Diff line number Diff line change
Expand Up @@ -15,4 +15,4 @@ DEPENDS = " \

inherit cmake_qt5 gtk-icon-cache

RRECOMMENDS_${PN} = "spotifyd"
RRECOMMENDS:${PN} = "spotifyd"
4 changes: 2 additions & 2 deletions dynamic-layers/meta-rust/spotifyd.bb
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
PV = "0.3.0"

# No unconditional start on each boot
#do_install_append() {
#do_install:append() {
# install -d ${D}${systemd_user_unitdir}
# install -m 644 ${S}/contrib/spotifyd.service ${D}${systemd_user_unitdir}
#}
Expand All @@ -37,7 +37,7 @@ PACKAGECONFIG[portaudio] = ",,portaudio"

CARGO_BUILD_FLAGS += "--features dbus_mpris,dbus_keyring,alsa_backend${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', ',pulseaudio_backend', '', d)}${@bb.utils.contains('PACKAGECONFIG', 'portaudio', ',portaudio_backend', '', d)}"

FILES_${PN} += "${systemd_user_unitdir}"
FILES:${PN} += "${systemd_user_unitdir}"

############################################################################
# The following parts were auto-generated by cargo-bitbake - have no idea
Expand Down
2 changes: 1 addition & 1 deletion recipes-graphics/ntk/ntk_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ WAF_EXTRA_CONF = " \
--libdir=${libdir} \
"

do_install_append() {
do_install:append() {
rm ${D}${libdir}/libntk.a
rm ${D}${libdir}/libntk.a.1
mv ${D}${libdir}/libntk.a.${PV} ${D}${libdir}/libntk.a
Expand Down
10 changes: 5 additions & 5 deletions recipes-gstreamer/gstreamer-0.10/gst-plugins-base_0.10.36.bb
Original file line number Diff line number Diff line change
Expand Up @@ -32,21 +32,21 @@ PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
PACKAGECONFIG[x11] = "--enable-x --enable-xvideo,--disable-x --disable-xvideo,virtual/libx11 libxv libsm libice"
PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"

do_configure_prepend() {
do_configure:prepend() {
# This m4 file contains nastiness which conflicts with libtool 2.2.2
rm -f ${S}/m4/lib-link.m4
}

do_configure_append() {
do_configure:append() {
# remove stay \ introduced by make 4.3
if make -v | grep '4\.3'; then
sed -i 's:\\#include:#include:g' `find -name Makefile`
fi
}

FILES_${PN} += "${datadir}/${BPN}"
FILES:${PN} += "${datadir}/${BPN}"

CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
CACHED_CONFIGUREVARS:append:x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"

# /usr/bin/gst-visualise-0.10 is a perl script.
RDEPENDS_${PN}-apps += "perl"
RDEPENDS:${PN}-apps += "perl"
26 changes: 13 additions & 13 deletions recipes-gstreamer/gstreamer-0.10/gst-plugins-package.inc
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PACKAGESPLITFUNCS_prepend = " split_gstreamer10_packages "
PACKAGESPLITFUNCS_append = " set_metapkg_rdepends "
PACKAGESPLITFUNCS:prepend = " split_gstreamer10_packages "
PACKAGESPLITFUNCS:append = " set_metapkg_rdepends "

python split_gstreamer10_packages () {
gst_libdir = d.expand('${libdir}/gstreamer-${LIBV}')
Expand All @@ -19,8 +19,8 @@ python set_metapkg_rdepends () {

pn = d.getVar('PN')
metapkg = pn + '-meta'
d.setVar('ALLOW_EMPTY_' + metapkg, "1")
d.setVar('FILES_' + metapkg, "")
d.setVar('ALLOW_EMPTY:' + metapkg, "1")
d.setVar('FILES:' + metapkg, "")
blacklist = [ pn, pn + '-meta' ]
metapkg_rdepends = []
pkgdest = d.getVar('PKGDEST')
Expand All @@ -37,20 +37,20 @@ python set_metapkg_rdepends () {
is_empty = len(dir_contents) == 0
if not is_empty:
metapkg_rdepends.append(pkg)
d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
d.setVar('DESCRIPTION_' + metapkg, pn + ' meta package')
d.setVar('RDEPENDS:' + metapkg, ' '.join(metapkg_rdepends))
d.setVar('DESCRIPTION:' + metapkg, pn + ' meta package')
}

# each plugin-dev depends on PN-dev, plugin-staticdev on PN-staticdev
# so we need them even when empty (like in gst-plugins-good case)
ALLOW_EMPTY_${PN} = "1"
ALLOW_EMPTY_${PN}-dev = "1"
ALLOW_EMPTY_${PN}-staticdev = "1"
ALLOW_EMPTY:${PN} = "1"
ALLOW_EMPTY:${PN}-dev = "1"
ALLOW_EMPTY:${PN}-staticdev = "1"

PACKAGES += "${PN}-apps ${PN}-meta ${PN}-glib"

FILES_${PN} = ""
FILES_${PN}-apps = "${bindir}"
FILES_${PN}-glib = "${datadir}/glib-2.0"
FILES:${PN} = ""
FILES:${PN}-apps = "${bindir}"
FILES:${PN}-glib = "${datadir}/glib-2.0"

RRECOMMENDS_${PN} += "${PN}-meta"
RRECOMMENDS:${PN} += "${PN}-meta"
2 changes: 1 addition & 1 deletion recipes-gstreamer/gstreamer-0.10/gst-plugins.inc
Original file line number Diff line number Diff line change
Expand Up @@ -21,7 +21,7 @@ PACKAGES_DYNAMIC += "^${PN}-.*"
# apply gstreamer hack after Makefile.in.in in source is replaced by our version from
# ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in, but before configure is executed
# http://lists.linuxtogo.org/pipermail/openembedded-core/2012-November/032233.html
oe_runconf_prepend() {
oe_runconf:prepend() {
if [ -e ${S}/po/Makefile.in.in ]; then
sed -i -e "1a\\" -e 'GETTEXT_PACKAGE = @GETTEXT_PACKAGE@' ${S}/po/Makefile.in.in
fi
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -53,7 +53,7 @@ gst_registry_binary_fill_feature(GList **list, GstPluginFeature *orig, GstBinary
chk->data = dest;
chk->size = sizeof (GstBinaryPluginFeature);

*list = g_list_append(*list, chk);
*list = g_list:append(*list, chk);

dest->rank = orig->rank;
if (!strncpy(dest->typename, name, GST_BINARY_REGISTRY_TYPENAME_TYPENAME_LEN) ||
Expand Down Expand Up @@ -149,7 +149,7 @@ gst_registry_binary_save_plugin(GList **list, GstRegistry *registry, GstPlugin *

chk->data = e;
chk->size = sizeof (GstBinaryPluginElement);
*list = g_list_append(*list, chk);
*list = g_list:append(*list, chk);

if (!strncpy(e->name, plugin->desc.name, GST_BINARY_REGISTRY_NAME_LEN) ||
!strncpy(e->description, plugin->desc.description, GST_BINARY_REGISTRY_DESCRIPTION_LEN) ||
Expand Down Expand Up @@ -235,7 +235,7 @@ gst_registry_binary_write_cache(GstRegistry *registry, const char *location)

magic_chunck->data = magic;
magic_chunck->size = sizeof (GstBinaryRegistryMagic);
to_write = g_list_append(to_write, magic_chunck);
to_write = g_list:append(to_write, magic_chunck);

/* Iterate trough the list of plugins in the GstRegistry and adapt them to our structures */
for (walk = g_list_last(registry->plugins); walk; walk = g_list_previous(walk))
Expand Down Expand Up @@ -410,7 +410,7 @@ gst_registry_binary_get_binary_plugin(GstRegistry *registry, gchar *in)
return -1;
}
gstfeat->plugin_name = g_strdup(plugin->desc.name);
plugin_features = g_list_prepend(plugin_features, gstfeat);
plugin_features = g_list:prepend(plugin_features, gstfeat);
}

GST_DEBUG("Added plugin \"%s\" to global registry from binary registry", plugin->desc.name);
Expand Down
4 changes: 2 additions & 2 deletions recipes-gstreamer/gstreamer-0.10/gstreamer_0.10.36.bb
Original file line number Diff line number Diff line change
Expand Up @@ -42,8 +42,8 @@ CACHED_CONFIGUREVARS += "ac_cv_header_valgrind_valgrind_h=no"
# apply gstreamer hack after Makefile.in.in in source is replaced by our version from
# ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in, but before configure is executed
# http://lists.linuxtogo.org/pipermail/openembedded-core/2012-November/032233.html
oe_runconf_prepend() {
oe_runconf:prepend() {
sed -i -e "1a\\" -e 'GETTEXT_PACKAGE = @GETTEXT_PACKAGE@' ${S}/po/Makefile.in.in
}
FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
FILES:${PN} += " ${libdir}/gstreamer-0.10/*.so"
Loading

0 comments on commit 42a6ec9

Please sign in to comment.